Details
  • Last release: 63.0.1
  • 4 days ago

Web Browser

Dependencies
  • HD_Station >= 3.2.2
  • HD_Station < 4.0.0

QTS
Requires QTS 4.2.1 or later

Models
TS-NASX86 64bits

Thanks for your support
  • 62.0.2 Released 1 month ago ( 29-09-2018 )
    Dependencies:
    • HD_Station >= 3.2.2
    • HD_Station < 4.0.0
  • 61.0.1 Released 4 months ago ( 08-07-2018 )
    Dependencies:
    • HD_Station >= 3.2.2
    • HD_Station < 4.0.0
  • 60.0 Released 6 months ago ( 10-05-2018 )
    Dependencies:
    • HD_Station >= 3.2.2
    • HD_Station < 4.0.0
  • 59.02 Released 7 months ago ( 11-04-2018 )
    Dependencies:
    • HD_Station >= 3.2.2
    • HD_Station < 4.0.0
  • 58.0.2 Released 8 months ago ( 05-03-2018 )
    Dependencies:
    • HD_Station >= 3.2.2
    • HD_Station < 4.0.0
  • 57.04 Released 10 months ago ( 07-01-2018 )
    Dependencies:
    • HD_Station >= 3.2.2
    • HD_Station < 4.0.0
  • 57.0 Released 10 months ago ( 31-12-2017 )
    Dependencies:
    • HD_Station >= 3.2.2
    • HD_Station < 4.0.0