Details
  • Last release: 2.09.01
  • vor 1 Woche

[ QLogitechMediaServer ]

( A way to install and uses LogitechMediaServer, on Qnap Nas-systems with QTS 4.0 or higher and 86/i*86/X86_64/arm5te/armhf/aarch64/arm_64 architecture ! )

It will install the latest LogitechMediaServer nightly (Unix Tarball (i386, x86_64, i386 FreeBSD, ARM EABI, PowerPC) version source on the Qnap, as can be found on the http://downloads.slimdevices.com website.

Out of the box has support for, Spotty, YouTube, Radio paradise, SqueezeSonic, Shairtunes2 and MusicIP (MusicMagicServer). IMPORTANT For shairtunes2 to work, bonjour has to be activate ! ( Keep in mind, the plugin have to be installed in the server settings pages. Only needed libraries/prg and needed extra CPAN modules are included ) QLogitechMediaServer will install a pure LMS in the SlimServer directory, and wont add any thing in there ! )
Now also has support for GoogleMusic from version 2.09.01

The only thing it supplies is a installation of LogitechMediaServer and a init-script so it will startup correctly. Startup commands for LogitechMediaServer, can be change if you’re a advanced user. The config file can be found in the .qpkg/LogitechMediaServer directory ( .QLMS.config), Read the PLEASE-README-FIRST.txt, included in the directory for more information. From version 2.00 changed, and does not depend on software of Qnap /QTS anymore. The command chroot and a proper kernel must be available in QTS. After installation can take a few minute, before you can access the webgui [port 9001], depending on how many plugins there are installed !

From version 2.00.00 startup is optimise's, to run on a server/nas-systeem. Keeping track of resources and how heavy, other software is running on it. ( For advanced user, can be adjust in the file . QLMS.config )

It's a standalone version, which does not need extra software like a Optware/Entware. Software like lame, mplayer ( wma support ), icedax ( CDDA2WAV ) and more is included. To give support one several plugings.

Included in the installation is,

Perl 5.24.4 with original cpan modules included. ( The arm5te has perl 5.20.4)

Mozilla-CA-20160104, 
IO-Socket-SSL-2.052.
Net-SSLeay-1.82. ( Build with openssl-1.0.2m )
Devel-NYTProf-6.05
Crypt-OpenSSL-Bignum-0.08
Crypt-OpenSSL-Random-0.11
Crypt-OpenSSL-RSA-0.28

MusicIP v 1.8. ( Not included in the arm CPU's installations ! )

From v1.07.3 MusicIP (1.8) is included, and when enabled, will run at startup of the LMS services. MusicIP can be enabled by adding a line [ MUSICIP=1 ] in the .QLMS.config file, or by doing [ touch .MUSICIP ] in the LogitechMediaServer/ directory. 
(Can be found in the resource-monitor of QNap, under QMusicIPServer if running!) The webgui is on ipnr:[10002].

On every startup of the services, will check on updates for LMS. If available will be upgraded ( Official and Nightly ), can be adjusted in the .QLMS.config file.

Questions or trouble regarding LogitechMediaServer itself , go to the SlimDevices forum website. 
http://forums.slimdevices.com

More information on MusicIP, go to https://www.spicefly.com/ or http://forums.slimdevices.com

No need to uninstall any old lms installations, from version 2.00.00, can be installed beside any other lms or perl installations.

Developing was quiet a challenge to do, and took quiet a lot of times and investigation, trying and testing. Also had to go very deep, in the way Qnap works and the layout of their software and filesysteem, and how Linux operates. But i think have kicked it, and release a very nice way to let LMS running without any trouble's or errors. ( most of the old errors and trouble came from older or missing software in the QTS )

IMPORTANT from version 2.01 add support for arm5te, arm-x41 and aarch64/arm_64
Tested and working, musicip is not included ! Installation is on own risk

Still having issue's or trouble, please be very clear and try to give as many info as possible !.
Keep in mind i only own a ts-453a to work with !

For those who send me a donations, thank you, gives me a feeling that all the work is appreciated.

QTS
To be used with

Models
TS-X41 TS-NASX86 64bits TS-NASX86 TS-ARM-X09 TS-X28A TS-ARM-X19

If you appreciate my work, you can use the donation button !